join
donate

NTP Bug 2382

Peer precision < -31 gives division by zero

  • Date Resolved: Development (4.2.7p367) 25 Apr 2013, Stable (4.2.8) 19 Dec 2014
  • References: Bug 2382 / CVE-2015-5219
  • Affects: ntp-4.2.5p111 up to and including 4.2.7p366. This includes ntp-4.2.6.
  • CVSS: (AV:N/AC:H/Au:M/C:N/I:N/A:P) Base Score: 1.7 (worst case)
  • Summary: If MINPOLL is set to 3 then it's possible to crash some versions of ntpd.
  • Mitigation:
    • If you decide to override the default value of minpoll, make sure you use a value of 4 or more.
    • Upgrade to 4.2.8p4, or later, from the NTP Project Download Page or the NTP Public Services Project Download Page. Yes, you could upgrade to 4.2.7p367 or later, but why would you want to run an intermediate development version instead of the latest supported stable version?
    • Monitor your ntpd instances.
  • Credit: This issue was reported by Juha Sarlin in April of 2013.


This topic: Main > SecurityNotice > NtpBug2382
Topic revision: r1 - 2015-10-23 - 09:00:46 - HarlanStenn
 
SSL security by CAcert
Get the CAcert Root Certificate
This site is powered by the TWiki collaboration platform
IPv6 Ready
Copyright & 1999-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors. Ideas, requests, problems regarding the site? Send feedback