join
donate

NTP Bug 2919

TALOS-CAN-0063: ntpq atoascii() potential memory corruption

  • Date Resolved: Stable (4.2.8p4) 21 Oct 2015
  • References: Sec 2919 / CVE-2015-7852
  • Affects: All ntp-4 releases running up to, but not including 4.2.8p4, and 4.3.0 up to, but not including 4.3.77
  • CVSS: (AV:N/AC:H/Au:N/C:N/I:P/A:P) Base Score: 4.0, worst case
  • Summary: If an attacker can figure out the precise moment that ntpq is listening for data and the port number it is listening on or if the attacker can provide a malicious instance ntpd that victims will connect to then an attacker can send a set of crafted mode 6 response packets that, if received by ntpq, can cause ntpq to crash.
  • Mitigation:
    • Implement BCP-38.
    • Upgrade to 4.2.8p4, or later, from the NTP Project Download Page or the NTP Public Services Project Download Page.
    • If you are unable to upgrade and you run ntpq against a server and ntpq crashes, try again using raw mode. Build or get a patched ntpq and see if that fixes the problem. Report new bugs in ntpq or abusive servers appropriately.
    • If you use ntpq in scripts, make sure ntpq does what you expect in your scripts.
  • Credit: This weakness was discovered by Yves Younan and Aleksander Nikolich of Cisco Talos.


This topic: Main > SecurityNotice > NtpBug2919
Topic revision: r1 - 2015-10-23 - 09:23:30 - HarlanStenn
 
SSL security by CAcert
Get the CAcert Root Certificate
This site is powered by the TWiki collaboration platform
IPv6 Ready
Copyright & 1999-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors. Ideas, requests, problems regarding the site? Send feedback