join
donate

NTP Bug 2952

Original fix for NTP Bug 2901 broke peer associations

  • Date Resolved: Stable (4.2.8p7) 26 Apr 2016; Dev (4.3.92) 26 Apr 2016
  • References: Bug 2952 CVE-2015-7704 / VU#718152
  • Affects: 4.2.8p4 up to but not including 4.2.8p7, and 4.3.77 up to, but not including 4.3.92
  • Summary: The fix for NtpBug2901 in ntp-4.2.8p4 went too far, breaking peer associations.
  • Mitigation:
    • Upgrade to 4.2.8p7, or later, from the NTP Project Download Page or the NTP Public Services Project Download Page.
    • Don't connect to ntp-4.2.8p4 thru p6 instances of ntpd using a peer association.
    • If you are running ntp-4.2.8p4 thru p6 instances of ntpd don't expect clients that connect to you with peer associations to work.
    • Monitor your ntpd instances.
  • This weakness was discovered by Michael Tatarinov , NTP Project Developer Volunteer


This topic: Main > SecurityNotice > NtpBug2952
Topic revision: r1 - 2016-04-27 - 02:38:13 - HarlanStenn
 
SSL security by CAcert
Get the CAcert Root Certificate
This site is powered by the TWiki collaboration platform
IPv6 Ready
Copyright & 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors. Ideas, requests, problems regarding the site? Send feedback