join
donate

NTP Bug 3119

Mode 6 unauthenticated trap information disclosure and DDoS vector

  • Date Resolved: 21 Nov 2016
  • References: Sec 3119 / CVE-2016-9311 / VU#633847
  • Affects: ntp-4.0.90 (21 July 1999), possibly earlier, up to but not including ntp-4.2.8p9, and ntp-4.3.0 up to, but not including ntp-4.3.94.
  • CVSS2: MED 4.9 (AV:N/AC:H/Au:N/C:N/I:N/A:C)
  • CVSS3: MED 4.4 CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H
  • Summary: ntpd does not enable trap service by default. If trap service has been explicitly enabled, an attacker can send a specially crafted packet to cause a null pointer dereference that will crash ntpd, resulting in a denial of service.
  • Mitigation:
    • Implement BCP-38.
    • Use "restrict default noquery ..." in your ntp.conf file. Only allow mode 6 queries from trusted networks and hosts.
    • Upgrade to 4.2.8p9, or later, from the NTP Project Download Page or the NTP Public Services Project Download Page
    • Properly monitor your ntpd instances, and auto-restart ntpd (without -g) if it stops running.
  • Credit: This weakness was discovered by Matthew Van Gundy of Cisco.


This topic: Main > SecurityNotice > NtpBug3119
Topic revision: r2 - 2016-11-22 - 06:18:50 - HarlanStenn
 
SSL security by CAcert
Get the CAcert Root Certificate
This site is powered by the TWiki collaboration platform
IPv6 Ready
Copyright & 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors. Ideas, requests, problems regarding the site? Send feedback